frame

Application only present when Photon connected to Zerynth host

As a beginner with the Photon I was happy to get a little LED flasher working. Imagine my disappointment on discovering that when I disconnected the Photon from my computer and attached it to a 5V power supply the application code didn't seem to be activated. How do I make the software loaded by uplink permanent, please?
Tagged:

Comments

  • Hi Steve,

    sorry for the late answer; this is a known bug that we have already fixed (will be available very soon).

    The problem is related to the the serial over USB driver; when the Particle Photon is powered up, it waits for Usb enumeration before opening the serial port.

    If the device is powered up externally, the USB enumeration never starts, deadlocking the serial port initialization. Simply adding a "ready" status to the serial usb driver state machine solves the problem.

    Matteo Cipriani
    Zerynth Support Team
  • Hi Matteo,

    Thanks very much for the response. I'll update Zerynth Studio as soon as the new release comes out.

  • Hi Steve,

    New Virtual Machine for Particle Photon enabled for stand alone functioning is now available.
    You don't need to update Zerynth Studio; all you have to do is to create a new Virtual Machine and to load new VM in your Particle Photon.

    Once loading new VM and uplinking your firmware, Particle Photon will be able to run the bytecode also when it will be powered up with an external power supply.

    Let me know if everything works well :)
    Matteo Cipriani
    Zerynth Support Team
Sign In or Register to comment.

ZERYNTH Community

@ 2016 Zerynth.com, all rights reserved.