frame

Installs but fails on start

When I do the install there are no issues but when I try to start the app it fails with the error:
Item to be inserted into menu already is in another menu

Model: MacBookPro13,3, BootROM MBP133.0226.B23, 4 processors, Intel Core i7, 2.6 GHz, 16 GB, SMC 2.38f7
Graphics: Radeon Pro 450, AMD Radeon Pro 450, PCIe, 2048 MB
Graphics: Intel HD Graphics 530, Intel HD Graphics 530, Built-In
Memory Module: BANK 0/DIMM0, 8 GB, LPDDR3, 2133 MHz, 0x802C, 0x4D5435324C31473332443450472D30393320
Memory Module: BANK 1/DIMM0, 8 GB, LPDDR3, 2133 MHz, 0x802C, 0x4D5435324C31473332443450472D30393320
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x15A), Broadcom BCM43xx 1.0 (7.21.171.126.1a2)
Bluetooth: Version 5.0.4f18, 3 services, 17 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
USB Device: USB 3.0 Bus
USB Device: iBridge
Thunderbolt Bus: MacBook Pro, Apple Inc., 19.6
Thunderbolt Bus: MacBook Pro, Apple Inc., 19.6

«1

Comments

  • anbaanba Member
    Hi Anthony,
    on Mac if the installation succeeds you should find Zerynth App and Zerynth Studio under Applications.
    Zerynth App must be ignored (is there as support for ZStudio), and running it may give that error. To start the IDE you have to run Zerynth Studio.
    If this does not solve your problem, can you please post here your operating system version?




    Andrea Baù
    Zerynth Support Team
  • Apologies for not being clear on this. I am talking about Zerynth Studio not Zerynth App. I say app as it is an application installed on the computer. The OSX version is 10.12.5.
  • edited July 21
    Hi Anthony,

    sorry for the late answer; unfortunately we cannot replicate your issue in our MacOS machine.
    We complete the installation in OSX version 10.12.5 from scratch and all works without errors.

    Have you more than one user in your MacOS machine? if yes, there is an active Zerynth installation related to other users? if no, has your user particular permission resctrictions? 

    Keep me posted

    Matteo Cipriani
    Zerynth Support Team
  • That's a possibility as I am using a laptop provided my my company to test this and I am not aware of how much is restricted on the system. I will attempt to do the install from the local admin account and see what that does.
  • Same problem about my MacBook Pro with El Capitan ver 10.11.6 (same as my son with Maverick version).
    Is a problem of OS? Need help. We try to install with Win version but we need OS version working. Can you help us?
  • Hi Alberto,

    Can you report your error log please?
    As mentioned before, have you, on your MacOS machine, more than one user? or permission restrictions in your user?

    Let me know :)
    Matteo Cipriani
    Zerynth Support Team
  • Unfortunately I still get the same issue when installing and running as the local admin account that does not have the restrictions that a network account does.
  • edited July 24
    The problem we have occours in two different Mac Pro: in both cases the program exit in a unexpected way as soon the green windows open.
    My Mac has El Capitain version, my son works in a different Mac pro with Maverick version. Tonight I'll provide complete info of the error as soon as I'll arrive at home.

  • Still one thing. No restriction are applied and we work as administrator
  • Here the message when app stops on Mac pro.

    I try to install also on 64bit Windows PC. The installation finish ok but when I launch the first time the app it stops during the upload of the library (tested in online and offline).

    So either in OS X either in Win64 we are not able to work.
    Can you help us?
    Regards
  • edited July 24
    Here the log when installation stops in win64.
    The PC has Win 10 ver 1703 build 15063.483
  • Hi Alberto,

    Regarding the issue related to installation on Windows 10 machine, internet connection is always required also for offline installation (it only helps to speed up the installation skipping the package downloading phase); ZerynthInstaller.exe must be executed from your main disk (same where your Windows distribustion is installed).
    By pressing F12 during installation phase, you can open the js console where more verbose log messages are shown.

    Regarding the MacOS problem, we installed successfully Zerynth Studio in Sierra and El Capitan distributions so we cannot replicate the issue. Reading from your and @Anthony's log, it seems like Zerynth Studio application menu generation in your machines is the cause of the crash.
    Opening "~/.zerynth2/dist/r2.0.9/studio/zjs/app.js" file, you can find from line 77 to line 161 Zerynth Studio application menu definition.
    You can try to comment or rename label names and start Zerynth Studio to discover which "Item to be inserted into menu already is in another menu" as descibed in your error log. Here below an example of change:

    ...
    //submenu.append(new nw.MenuItem({label:"About",click:()=>{Dialogs.modal("AboutModal")}}))
    //menu.append(new nw.MenuItem({label:"Help",submenu:submenu}))
    ... or ... submenu.append(new nw.MenuItem({label:"ZAbout",click:()=>{Dialogs.modal("AboutModal")}})) menu.append(new nw.MenuItem({label:"ZHelp",submenu:submenu})) ...
    In the mean time, as soon as possible, I try to prepare for you a new app.js file to better debug this issue and if you don't succeed to solve with previous advices, we can try this other way.

    Please try again both installations and let me know the results.
    Matteo Cipriani
    Zerynth Support Team
  • Many many thanks. As soon as return home thursday I'll try and let you know
  • edited July 25
    Regarding win64 I provide you in my post of yesterday the install log in txt file. It is not necessary pressing F12 due to the fact that the installation stops at the point shown by the log.
    You can see from this file the installation history
  • Sorry, my bad.
    I missed it and I saw only the MacOS error log.  :#

    So you confirm me that during Windows installation you had an internet connection active?
    Matteo Cipriani
    Zerynth Support Team
  • edited July 25
    Yes I confirm and I disabled firewall and antivirus avast pro too.
  • Any new about problems?
  • edited July 26
    Found the problem for the unexpected exit on Mac. The problem is the line:
    app.update_uninst_menu() in app.js
    when commented program start
    pls have we problems if comment this line?
    Let me know
  • I try to work with Studio opening without the line commented (see post overthere).
    If I connect particle photon it does not appear in the list of Targets.
  • Hi Alberto,

    About Windows issue, I prepare for you new "ztc.js" file that you have to replace in this path:

    "C:\Program Files\Zerynth\js\ztc.js"

    After replacing this file, you can start again the installation (if you press F12 during installation you can expand js objects to better visualize single voices that are not displayed in text file).

    Even if installation ends without errors, please send me new log file to better understand the exception raised; in particular, you can find, in javascript console, the "loccmd" object and post me this object in both (expanded and not expanded) representations. 

    Let me know if this can help you
    ztc.zip 960B
    Matteo Cipriani
    Zerynth Support Team
  • @Alberto and @Anthony, ;

    about your MacOS, I prepare for you new "app.js" file that you have to replace in this path:

    MacOS: "~/.zerynth2/dist/r2.0.9/studio/zjs/app.js"

    Windows: C:\Users\your_user\zerynth2\dist\r2.0.9\studio\zjs\app.js"

    Please let me know if this can fix your problem or post me new error log messages, if there are.
    app.zip 9.3K
    Matteo Cipriani
    Zerynth Support Team
  • Many many thanks. It works on Mac Pro. Now I test in Win64
  • edited July 27
    I'm testing with new ztc.js file....
  • Commenting out the line app.update_uninst_menu() that is not in the if statement fixed the issue for me, many thanks as this fix came in time for me to work with my son on this during my vacation.
  • Now all ok with the installation in win64.
    But when I launch Zerynth the app and menus are ok but this message comes out:
    Loading settings...
    Ready!
    Error loading targets: SyntaxError: Unexpected end of JSON input
    Error: Zerynth autocompletion disabled SyntaxError: Unexpected end of JSON input
    Checking for updates...
    Error while setting token! SyntaxError: Unexpected end of JSON input
    Error while checking for updates:SyntaxError: Unexpected end of JSON input
    WARNING!! Can't retrieve user info!

  • edited July 27
    Appled also app.js as suggested for MacOS but the result is the same


  • Hi there,

    I'm running Mac OS 10.12.5 (Sierra). Downloaded Studio and installed it by copying it to the APplications folder. The first time I tried to run it, as expected it asked me whether I wanted an online or offline installation. I selected online, and things seems to go OK, but then the application crashed. Now it crashes reliably on each startup:

    Process:               Zerynth [42246]
    Path:                  /Users/USER/*/Zerynth.app/Contents/MacOS/Zerynth
    Identifier:            com.zerynth.zerynth
    Version:               54.0.2840.99 (2840.99)
    Code Type:             X86-64 (Native)
    Parent Process:        ??? [1]
    Responsible:           Zerynth [42246]
    User ID:               502

    Date/Time:             2017-07-29 14:56:51.944 +0100
    OS Version:            Mac OS X 10.12.5 (16F73)
    Report Version:        12
    Anonymous UUID:        695FFA99-CD0E-D83C-ABD0-3420874BDB75

    Sleep/Wake UUID:       750DC716-6A59-46E2-8C3D-BA2CA107BC30

    Time Awake Since Boot: 580000 seconds
    Time Since Wake:       1400 seconds

    System Integrity Protection: enabled

    Crashed Thread:        0  CrBrowserMain  Dispatch queue: com.apple.main-thread

    Exception Type:        EXC_BAD_INSTRUCTION (SIGILL)
    Exception Codes:       0x0000000000000001, 0x0000000000000000

    Application Specific Information:
    Crashing on exception: Item to be inserted into menu already is in another menu

    I replaced the app.js file as recommended, and all was well. A new release that fixes this error would be welcome when you get time ...
  • I had Changed app.js also on Mac of my son (with Maverick version of OS). He had the error. So on Mac with El Capitan (my Mac) all ok, on Mac with Maverick (my son) he continue to have errors and the same on my win64 as I explained above. Thanks if you can do something next week as my son is working on particle photon and he is not able to recognise it due to the error
  • Hello everyone,

    our next release (coming very soon) will fix the MacOS installation issue related to "Item to be inserted into menu already is in another menu" error.

    Regarding the "Unexpected end of JSON input" error (1) in Windows machine and the software crash (2) on Mavercks MacOS distribution, I need more info:
    1. please press F12 on opening Zerynth Studio and post me all output messages of the javascript console;
    2. please post me all error messages coming out from installation after changing the app.js file.
    Thanks for your feedbacks.
    Matteo Cipriani
    Zerynth Support Team
  • edited July 31
    Hi. I begin to post the javascript console for win64
     (see pdf file attached - I remove the token with my credentials google+)

    What it displays is that C:\Users\Alberto\zerynth2\cfg\token.json' is not present (and it is true!!) and the following message: 

    <Uncaught (in promise) SyntaxError: Unexpected end of JSON input
        at JSON.parse (<anonymous>)
        at ztc.js:33
        at Object.command (ztc.js:8)
        at Object.load_packs (eval at globalEval (jquery.min.js:2), <anonymous>:94:18)
        at Object.init (eval at globalEval (jquery.min.js:2), <anonymous>:67:19)
        at eval (eval at globalEval (jquery.min.js:2), <anonymous>:1:13)
        at eval (<anonymous>)
        at Function.globalEval (jquery.min.js:2)
        at n.fn.init.domManip (jquery.min.js:3)
        at n.fn.init.replaceWith (jquery.min.js:3)>

    In any case in the pdf file you can find all what you have requested
    Let me know
Sign In or Register to comment.

ZERYNTH Community

@ 2016 Zerynth.com, all rights reserved.